Email Delivery Disruption Notice

Incident Enviso platform Enviso Sales App Enviso Trade App
2026-02-21 09:00 CET · 2 hours

Updates

Post-mortem

Dear customer,

We would like to provide a clarification regarding the incident reported on Saturday the 21st between 09:00 and 11:00 CET.

During this timeframe, we observed what appeared to be a temporary issue within our email delivery system. As a precaution, and based on the information available at the time, our on-call engineers acted quickly to minimize any potential impact. To ensure that no communication was lost, all emails sent during the affected period were retriggered.

Following a more detailed technical analysis, we have now confirmed that there wasn’t any disruption and all emails were delivered successfully. The issue was limited to an internal monitoring address that was bouncing messages.

We are currently improving our monitoring and alerting processes to prevent similar situations in the future.

We appreciate your understanding and thank you for your continued trust.

Team Vintia

February 23, 2026 · 14:37 CET
Update

Following our previous communication regarding the temporary email delivery issue, we would like to inform you that we have now successfully resent all previously failed email deliveries.

We appreciate your patience and understanding.

February 21, 2026 · 19:05 CET
Update

We are currently working on a solution to retrigger all failed email deliveries. We will keep you posted once the process is completed.

February 21, 2026 · 15:04 CET
Issue

We would like to inform you that we had experienced a temporary issue with our email delivery system between February 21, 2026 08:00 UTC to February 21, 2026 10:00 UTC

As a result, some emails may not have reached customer inbox during that period. The issue has been identified and fully resolved.

We are also continuously optimizing our monitoring systems to help prevent similar issues in the future and ensure more reliable communication.

We sincerely apologize for the inconvenience and appreciate your patience.

February 21, 2026 · 14:04 CET

← Back